Would be good to split the rules for test classes / methods from other rules.
E.g. it’s perfectly OK to have 100 test methods. Not cool to have that many methods in a normal class.
Naming convention for a test method may be:
nameOfMethod_whenPassingThis_shouldDoThis, but that format is not appropriate in a normal method